Back to overview
Downtime

Domain Expired

Oct 20 at 11:54am UTC
Affected services
jooo.tech
api.jooo.tech
msg.jooo.tech
kbg.jooo.tech

Resolved
Oct 20 at 11:55am UTC

The domain has been renewed

Created
Oct 20 at 11:54am UTC

Domain expired and had to be renewed